Re: [code] [textadept] Curses build error

From: Mitchell <m.att.foicica.com>
Date: Thu, 9 May 2013 19:46:16 -0400 (EDT)

Hi Chris,

On Thu, 9 May 2013, Chris Emerson wrote:

> Hi,
>
> On Tue, May 07, 2013 at 10:22:09PM +0100, Chris Emerson wrote:
>> Hi Mitchell,
>>
>> On Tue, May 07, 2013 at 03:49:13PM -0400, Mitchell wrote:
>>> Hi Chris,
>>>
>>> On Tue, 7 May 2013, Chris Emerson wrote:
>>>
>>>> Hi,
>>>>
>>>> On CentOS 6.2, I get an error building ScintillaTerm.cxx (from hg):
>>>> [snip]
>>>
>>> What version of ncurses do you have?
>>
>> I haven't got access to it right now, but I'm fairly sure it's 5.7.
>
> It's 5.7, and NCURSES_VERSION_PATCH is 20090207. NCURSES_WIDECHAR doesn't
> appear anywhere in /usr/include.

Thank you. I looked at previous releases of ncurses, and only starting at
5.8 is NCURSES_WIDECHAR defined. It used to be _XOPEN_SOURCE_EXTENDED (and
still is on Mac OSX) so I committed a check for that too in Scinterm hg.

Hopefully it works now.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Thu 09 May 2013 - 19:46:16 EDT

This archive was generated by hypermail 2.2.0 : Fri 10 May 2013 - 06:29:02 EDT