Re: [code] TA 6.6 beta issue

From: Ryan Pusztai <rpusztai.att.gmail.com>
Date: Thu, 20 Jun 2013 10:05:41 -0400

Mitchell,

On Thu, Jun 20, 2013 at 10:02 AM, Mitchell <m.att.foicica.com> wrote:

> Ryan,
>
> On Thu, 20 Jun 2013, Ryan Pusztai wrote:
>
> Mitchell,
>>
>> On Thu, Jun 20, 2013 at 9:51 AM, Mitchell <m.att.foicica.com> wrote:
>>
>> Ryan,
>>>
>>>
>>> On Thu, 20 Jun 2013, Ryan Pusztai wrote:
>>>
>>> Hi,
>>>
>>>>
>>>> When I edit and use autocomplete I am getting an error.
>>>>
>>>> error message:
>>>> ...i/bin/textadept_6.6.x86_64/****modules/textadept/editing.**lua:**225:
>>>> bad
>>>>
>>>> argument #1 to 'ipairs' (table expected, got string)
>>>>
>>>>
>>> The API for autocomplete[1] changed. Do you have a custom key binding? If
>>> so, it probably needs to be updated.
>>>
>>
>>
>> You are correct I have a simple key binding
>>
>> -- Make Ctrl+Space the autocomplete key sequence.
>> keys['c '] = { m_editing.autocomplete_word, '%w_' }
>>
>> But I am not sure after reading the docs, what I should change it to. Can
>> you explain what should be passed to 'autocomplete_word()'? Thanks.
>>
>
> Sure, change to:
>
> keys['c '] = m_editing.autocomplete_word
>
> You no longer need the string argument :)

Sorry it was more simple, I was trying to figure out how to pass the words
in. That is what I thought the parameter needed.

--
Regards,
Ryan
-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Thu 20 Jun 2013 - 10:05:41 EDT

This archive was generated by hypermail 2.2.0 : Fri 21 Jun 2013 - 06:36:39 EDT