Re: [code] [textadept] Textadept 7.0 beta 4

From: Mitchell <m.att.foicica.com>
Date: Tue, 1 Oct 2013 16:43:54 -0400 (Eastern Daylight Time)

Ryan,

On Tue, 1 Oct 2013, Ryan Pusztai wrote:

> So I missed changing 'gui.' to 'ui.', but the error is not helpful at all
> when figuring out what I missed next. I do currently use Common, but I
> forked it because I went a different way with the display_name module. You
> can check out "beta 2" working Common here:
> https://github.com/rjpcomputing/ta-common
>
> This is the hardest update I have had so far. So I think there might be a
> root cause to the error I am getting.

bracematching.lua:
   Replace _M.textadept with textadept

comments.lua:
   Replace _M.textadept with textadept

   Note: this file is not needed since comments are now built-in.

display_filename.lua
   Replace gui.title with ui.title

enclose.lua
   Replace _M.textadept with textadept

I don't know what other modules you are loading from your init.lua, but
thse changes allowed me to load your 'common' module without error. There
is still work to be done, but at least you are not getting the cryptic
crashes on startup.

I hope that helps.

Cheers,
Mitchell

> --
> Regards,
> Ryan
>
>
> On Tue, Oct 1, 2013 at 3:14 PM, Robert Gieseke <rob.g.att.web.de> wrote:
>
>> Am 10/1/13 8:52 PM, schrieb Ryan Pusztai:
>> […]
>>
>> I am not sure what is going wrong. I did do the update and went through my
>>> .textadept files to switch from beta 2 to beta 4.
>>>
>>> Here is the error:
>>>
>>> $ ~/bin/textadept
>>>> ...extadept_7.0_beta_4.x86_64/**modules/textadept/editing.lua:**107:
>>>> attempt
>>>> to call method 'get_lexer' (a nil
>>>>
>>> […]
>>
>>
>>> Details:
>>> * Ubuntu x64 13.04
>>>
>>> It does start up when I run with an empty .textadept directory. I also
>>> added a 'properties.lua' and it worked. It happens when I use my init.lua
>>> and keys.lua. Any ideas?
>>>
>>> I just pushed some updates for my common module, these might be helpful
>> in case you use it. (There are still lots of issues though.)
>> Otherwise I just commented out everything in my `.textadept` when updating
>> and added module by module to see if and where it breaks…
>>
>> Hope this helps,
>> Robert
>>
>> --
>> You are subscribed to code.att.foicica.com.
>> To change subscription settings, send an e-mail to code+help.att.foicica.com.
>> To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
>>
>>
>

Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Tue 01 Oct 2013 - 16:43:54 EDT

This archive was generated by hypermail 2.2.0 : Tue 01 Oct 2013 - 17:19:36 EDT