Re: [code] C++ Support

From: Ryan Pusztai <rpusztai.att.gmail.com>
Date: Tue, 3 Jun 2014 09:02:14 -0400

Hi Mitchell,

On Mon, Jun 2, 2014 at 4:38 PM, Mitchell <m.att.foicica.com> wrote:

> OK that sounds acceptable. But now how do I get my post_init.lua to load.
>> It doesn't seem to get loaded at all. I did as you said above and simply
>> copied the file and replaced the ansi_c with cpp. Now I have
>> *~/.textadept/modules/cpp/init.lua* and my "post_init.lua" is located
>> *~/.textadept/cpp/post_init.lua*. Do I need to do something else to make
>> it
>> load this file automatically? I added a "ui.print( "Loading CPP
>> post_init.lua" )" to the top of the file and it never shows the [Message
>> Buffer].
>>
>
> Your *post_init.lua* should be in *~/.textadept/modules/cpp/post_init.lua*.
> (Note the "modules" subdirectory, which matches Textadept's module
> directory structure.) Once you make that change, your print statement
> should fire.

That worked. What did I miss? I have a Lua *post_init.lua* file and I put
that in *~.textadept/lua/post_init.lua* and that seems to work. Should I
switch to *~/.textadept/modules/lua/post_init.lua*? Is there something in
the packaged Lua module that loads those files, so I could add that to my
CPP module?

Thanks.

--
Regards,
Ryan
-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Tue 03 Jun 2014 - 09:02:14 EDT

This archive was generated by hypermail 2.2.0 : Wed 04 Jun 2014 - 06:36:12 EDT