Re: [code] [textadept] Odd indicator/view_ws interaction

From: Mitchell <m.att.foicica.com>
Date: Fri, 12 Dec 2014 12:41:14 -0500 (EST)

Hi Chris,

On Thu, 11 Dec 2014, Chris Emerson wrote:

> Hi,
>
> In Curses Textadept 7.8 beta, I get some strange display issues for text
> with an indicator, when buffer.view_ws=1:
>
> * Spaces which are indicated show as "~"

I can reproduce this in my PuTTY v0.63 with DejaVu Sans Mono. I don't
believe this is the fault of Textadept because none of the dialogs are
drawn properly for me, so neither would whitespace bullets.

> * Indentation guides, when highlighted, show as ≠ (not-equal character).

I cannot reproduce this.

> * If I highlight (using indicators) leading whitespace, which normally looks
> like:
>
> ····|···width·=·4
>
> and like this when indicated (with blue background in my case):
>
> ····≠···width·=·4

I get proper highlighting and '|' instead of not equals.

> If I type "foo" into the text, it becomes odd characters:
>
> ·├ │├▒ ⎻├ ······width·=·4
>
> I typed "Textadept" from the second character in the indicator.

I cannot reproduce this.

> I'm using PuTTY 0.63 with DejaVu Mono, in case that affects it.

I seem to recall plenty of PuTTY issues since the terminal version came
out... I'm not sure what can be done about it. Please let me know if you
have any ideas.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Fri 12 Dec 2014 - 12:41:14 EST

This archive was generated by hypermail 2.2.0 : Sat 13 Dec 2014 - 06:32:28 EST