Re: [code] [textadept] Odd indicator/view_ws interaction

From: Mitchell <m.att.foicica.com>
Date: Mon, 16 Mar 2015 10:43:14 -0400 (EDT)

Hi Chris or anyone else that can reproduce this issue,

On Sat, 14 Mar 2015, Chris Emerson wrote:

> Hi Mitchell,
>
> On Fri, Dec 12, 2014 at 12:41:14PM -0500, Mitchell wrote:
>> Hi Chris,
>>
>> On Thu, 11 Dec 2014, Chris Emerson wrote:
>>
>>> Hi,
>>>
>>> In Curses Textadept 7.8 beta, I get some strange display issues for text
>>> with an indicator, when buffer.view_ws=1:
>>>
>>> * Spaces which are indicated show as "~"
>>
>> I can reproduce this in my PuTTY v0.63 with DejaVu Sans Mono. I
>> don't believe this is the fault of Textadept because none of the
>> dialogs are drawn properly for me, so neither would whitespace
>> bullets.
>
> I've just noticed this tilde behaviour happens in gnome-terminal with
> whatever the "Monospace 10" font is - so I don't think it's a PuTTY issue.

Please do me a favor and search "src/scintilla/term/ScintillaTerm.cxx" for
"ACS_BULLET" and change that line to this:

   rc.right = (int)rc.right, ch = ACS_BULLET | A_BOLD | A_ALTCHARSET;

Then recompile and try it in gnome-terminal and let me know if it works. I
don't have gnome-terminal and the means to test this myself.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 16 Mar 2015 - 10:43:14 EDT

This archive was generated by hypermail 2.2.0 : Tue 17 Mar 2015 - 06:46:40 EDT