Re: [code] [textadept] Textadept 8.0 alpha

From: Mitchell <m.att.foicica.com>
Date: Mon, 13 Apr 2015 11:21:19 -0400 (EDT)

Hi Chris,

On Thu, 2 Apr 2015, Chris Emerson wrote:

> Hi Mitchell,
>
> On Wed, Apr 01, 2015 at 04:40:16PM -0400, Mitchell wrote:
>> Textadept 8.0 alpha is released from http://foicica.com/textadept
>
> I also tried textadeptjit-curses, which mostly works well as well, but
> I had to change a "local lfs = require('lfs')" in my profile to just
> "local lfs = _G.lfs". I don't think this is new to 8.0a - it also happens
> on 7.9. For some reason require('lfs') works on the non-luajit version
> but raises an error about not finding it in luajit.

It appears to have been introduced in lfs 1.6.2, at least 9 months ago,
but I'm not sure how. I don't know enough about Lua 5.1/LuaJITs module
architecture to fix this.

If anyone can supply a patch (probably against lfs itself), I'll commit
it to Textadept's build process.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 13 Apr 2015 - 11:21:19 EDT

This archive was generated by hypermail 2.2.0 : Tue 14 Apr 2015 - 06:33:28 EDT