Re: [code] [textadept] syntax error question

From: Giovanni Salmeri <g.salmeri.att.mondodomani.org>
Date: Thu, 3 Sep 2015 14:37:48 +0200

> Textadept is using 'luac', which probably points to a version of Lua
> on your system that is 5.1 or 5.2.

Thank you very much for the hint! Unfortunately no Lua 5.3 in the
repositories of Ubuntu 12.04 (the version I'm currently using). But I
installed it manually from
https://packages.debian.org/sid/amd64/lua5.3/download and then I gave
the command:

sudo update-alternatives --install /usr/bin/luac
lua-compiler /usr/bin/luac5.3 121

(121 is the priority of Lua5.2 + 1)

Problem solved!

-- 
Giovanni Salmeri
http://mondodomani.org/pers/salmeri/
-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Thu 03 Sep 2015 - 08:37:48 EDT

This archive was generated by hypermail 2.2.0 : Fri 04 Sep 2015 - 06:27:40 EDT