Re: [code] Lexer creation problem.

From: Mitchell <m.att.foicica.com>
Date: Mon, 16 Nov 2015 20:37:46 -0500 (EST)

Hi Michael,

On Sun, 15 Nov 2015, Michael Richter wrote:

> OK, I have a minimalist language module for SNOBOL4 now. It features the
> lexer, run support, and error patterns for running and syntax checking. As
> I figure out what's plausible in terms of API support and autocompletion
> I'll add them as well, but at the moment this is out of scope. (I'm not
> exactly sure, even, how I'd go about doing it yet.)
>
> I've attached the module to this email.

Thanks so much for your contribution! I've included your run command,
syntax command, and error patterns in Textadept, so they are no longer
required in your language module's `init.lua`. SNOBOL4 support will show
up in tonight's nightly :)

All of Textadept's official language modules have autocompletion support,
so you can reference them if you'd like. The main thing to do is just
implement a `textadept.editing.autocompleters.snobol4` function[1] that
returns autocompletion info. See the API documentation for more details.
If you have any questions, please ask. Also, don't feel like implementing
autocompletion is a requirement :) It's completely up to you how much
you'd like to support that language. When you finish, I encourage you to
post it to the wiki!

Cheers,
Mitchell

[1]: http://foicica.com/textadept/api.html#textadept.editing.autocompleters

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 16 Nov 2015 - 20:37:46 EST

This archive was generated by hypermail 2.2.0 : Tue 17 Nov 2015 - 06:31:07 EST