Re: [code] [textadept] Single Instance Support on Windows and glib 2.28+ Bump

From: Mitchell <m.att.foicica.com>
Date: Mon, 1 Feb 2016 20:24:59 -0500 (EST)

On Mon, 1 Feb 2016, Mitchell wrote:

> Hi,
>
> Thanks to Carl Sturtivant, the Windows GUI version of Textadept now supports
> single instance functionality, bringing it to parity with the other supported
> platforms. This will be available starting in tonight's nightly build
> (assuming it builds properly on the build server). If you don't want this on
> Windows, you can create a shortcut to Textadept that passes the `-f` flag,
> just like you would similarly do on the other platforms.
>
> I'm also taking this opportunity to remove support for compiling Textadept
> against versions of glib earlier than 2.28 (which has been required for
> single instance functionality). If you've been running the pre-compiled
> binary versions of Textadept, this does not affect you. If you've been
> compiling Textadept against glib < 2.28, you'll have to update glib or use a
> patch. From the manual: "For reference, Ubuntu 11.04, Debian Wheezy, Fedora
> 15, and openSUSE 11.4 support GLib 2.28 or later."
>
> There's some more documentation in the changeset[1] if you're interested.

[1]: http://foicica.com/hg/textadept/rev/832af084b4b2

Changeset above. Sorry for the omission.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 01 Feb 2016 - 20:24:59 EST

This archive was generated by hypermail 2.2.0 : Tue 02 Feb 2016 - 06:55:02 EST