[code] [scintillua] Scintillua 3.6.4-2

From: Mitchell <m.att.foicica.com>
Date: Mon, 4 Apr 2016 19:03:47 -0400 (EDT)

Hi,

Scintillua 3.6.4-2 is released from http://foicica.com/scintillua

Scintillua adds dynamic Lua LPeg lexers to Scintilla. It is the quickest
way to add new or customized syntax highlighting and code folding for
programming languages to any Scintilla-based text editor or IDE.
Scintillua was designed to be dropped into or compiled with any Scintilla
environment. Scintillua may also be used as a Lua library for obtaining
syntax highlighting information of source code snippets.

This release addresses an issue in the 3.6.4-1 release. I'm very sorry for
any inconvenience that release caused. If you are using custom themes,
please note the change below, as you may be affected. If you have any
questions, please feel free to contact me.

Bugfixes:

   * Fixed bug with loading default themes in 3.6.4-1.

Changes:

   * Themes must require('lexer') now (if they are not already), and cannot
     rely on lexer to be globally defined. **This is a breaking change.**

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 04 Apr 2016 - 19:03:47 EDT

This archive was generated by hypermail 2.2.0 : Tue 05 Apr 2016 - 06:31:17 EDT