Re: [code] [textadept] GUI framework

From: Pedro Andres Aranda Gutierrez <paaguti.att.gmail.com>
Date: Wed, 13 Jul 2016 08:27:48 +0200

GTK3 on Ubuntu 16.04 works like a charm.
El 12/7/2016 22:58, "Mitchell" <m.att.foicica.com> escribió:

> Hi Robert,
>
> On Tue, 12 Jul 2016, Robert Gieseke wrote:
>
> Hi,
>>
>> I don't know what the state of portin Textadept to GTK3 is but I just
>> wanted to mention the `libui` toolkit, which is a in-development "simple
>> and portable (but not inflexible) GUI library in C that uses the native
>> GUI technologies of each platform it supports" - so Windows, OS X and
>> GTK3.
>>
>
> Textadept can be compiled against GTK3 on Linux (`make GTK3=1`). I haven't
> tried against a recent version of GTK3, but it worked the last time I ran
> it.
>
> Might be something for Textadept at some point - while the current
>> cross-platform build works well, there have been always requests for
>> native versions. Lua bindings are also available so this could maybe
>> make it easier to extend the GUI side of Textadept.
>>
>> There was also some discussion suggesting embedding Scintilla[1] in
>> `libui`.
>>
>
> libui looks interesting, but as a very young and immature project, it's
> far too early to pass judgement. Having Scintilla work with it is certainly
> a requirement.
>
> Thanks for sharing!
>
> Cheers,
> Mitchell
> --
> You are subscribed to code.att.foicica.com.
> To change subscription settings, send an e-mail to code+help.att.foicica.com.
> To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
>
>

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Wed 13 Jul 2016 - 02:27:48 EDT

This archive was generated by hypermail 2.2.0 : Wed 13 Jul 2016 - 06:51:33 EDT