Re: [code] How to set "wrap mode" to default to WRAP_WORD on Textadept launch?

From: Robert Gieseke <rob.g.att.web.de>
Date: Mon, 28 Nov 2016 19:25:42 +0100

Hi David,

these settings need to go into ~/.textadept/properties.lua

https://foicica.com/textadept/manual.html#Buffer.Settings

You can take a look at Textadept's properties.lua for all default
settings and take the ones you like to overwrite in your custom one.

Cheers,
Robert

Am 28/11/16 um 19:12 schrieb David Reimer:
> I have a ~/.textadept/init.lua file from which I call "ui.set_theme()"
> successfully.
>
> I would like to make Textadept launch with the "wrap mode" toggled
> "on". However, in spite of reading documentation and searching this
> mail archive, I can't convince it to work. I'm clearly getting the
> syntax wrong!
>
> Here are some of my failures:
>
> buffer.wrap_mode = 1
>
> buffer.wrap_mode = WRAP_WORD
>
> buffer.wrap_mode = buffer.WRAP_WORD
>
> As well as each of those options with "textadept." prefixed. None of
> them work, and they throw different errors on launch, with "attempt to
> index a nil value (field 'buffer')" being the most common (and with
> one it just silently fails).
>
> If someone could give me the correct line/syntax, I would be most grateful!
>
> David
>

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 28 Nov 2016 - 13:25:42 EST

This archive was generated by hypermail 2.2.0 : Tue 29 Nov 2016 - 06:52:48 EST