Re: [code] [textadept] to JIT or not to JIT...

From: Mitchell <m.att.foicica.com>
Date: Fri, 3 Mar 2017 08:34:42 -0500 (EST)

Hi Gabriel,

On Fri, 3 Mar 2017, Gabriel Dubatti wrote:

> Hi,
>
> I've always wondered why there are 2 TA versions for gui and 2 for the
> curses.
> I guess the JIT version should run faster but be "less compatible" in
> some way.
> I do not use the JIT version because I've never seen an impressive speed
> up and to be in the safe side.
>
> What version of Textadept are you running?

I always use the non-JIT version.

> Is there any valid reason to use the JIT or the non JIT version?

One reason you might want to use the JIT version is if you want access to
LuaJIT's FFI features.

> Wouldn't be better to discard the JIT version and go to 64 bits in the
> Windows version?

Some time ago I asked the list if it was worth dropping the JIT version,
but some people depend on it quite heavily. Since LuaJIT rarely changes,
maintenance so far has been minimal.

> Maybe I'm missing something completely.

No, not at all. Very valid points you bring up. Do you have a particular
need for 64-bits? Last time I checked (a couple of years ago) there were
no pre-compiled 64-bit versions of GTK 2.24 for Windows. There was a 2.22
build that I experimented with, but 2.24 is needed. I suspect most of the
work is going into GTK 3.x on Windows, sadly.

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Fri 03 Mar 2017 - 08:34:42 EST

This archive was generated by hypermail 2.2.0 : Sat 04 Mar 2017 - 06:33:04 EST