[code] [textadept] No Localization:context

From: cryo shock <axteffekt.att.gmail.com>
Date: Mon, 1 May 2017 22:36:05 +0200

Hi guys,

in TA 9.3 I had manually modified the TA\modules\textadept\menu.lua as I
added a context menu entry for the snippet menu:

local default_context_menu = {
...
  SEPARATOR,
  {_L['Insert _Snippet...'], textadept.snippets._select}

The funny thing is, that this worked on one of my PCs. The context menu
entry said:
Insert Snippet...
One another PC though the context menu entry said:
No Localization:Insert Snippet...

Now I updated to v9.4 and added the very same line as before. On my first
mentioned PC now the menu entry also says:
No Localization:Insert Snippet...
What exactly didn't I localize? A path or... code block? All the lines
above mine are build up the same as far as I can tell, i.e.:
{_L['Select _All'], buffer.select_all}

I checked the API manual for localize and Localization but tbh it didn't
enlighten me.

Second:
How can I integrate this change to my init.lua? Or should I duplicate the
folder structure and menu.lua from the TA folder to my ~\.textadept folder?

Third question:
Can I also add changes for other files (in my case the
TA\share\themes\MS-Windows\gtk-2.0\gtkrc) to my init.lua or only to .lua
files?

Thanks in advance for any help, and thanks for v9.4 Mitchell.

Cheers, Sebastian

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 01 May 2017 - 16:36:05 EDT

This archive was generated by hypermail 2.2.0 : Tue 02 May 2017 - 06:52:54 EDT