Re: [code] some unicode not rendering

From: David Reimer <djreimer.att.gmail.com>
Date: Sat, 13 May 2017 09:16:16 +0100

On 13 May 2017 at 05:00, <code+help.att.foicica.com> wrote:

>
> ---------- Forwarded message ----------
> From: Pedro Andres Aranda Gutierrez <paaguti.att.gmail.com>
> To: code.att.foicica.com
> Cc:
> Bcc:
> Date: Thu, 11 May 2017 08:30:24 +0200
> Subject: Re: [code] some unicode not rendering
> Hi,
>
> Since I live in an 'accented' world (Spanish, German and other languages I
> speak go beyond the seven bits) ;-) I'm always interested in this kind of
> issues. My test pages are:
>
> https://www.w3.org/2001/06/utf-8-test/postscript-utf-8.html, which covers
> 98% of my needs and
> http://www.fileformat.info/info/unicode/block/cyrillic/utf8test.htm for
> occasional Russian texts.
>
> The problem Carl reports can be even worse, because it also happens on my
> Mac with the Monaco font.
>

But isn't this at least (in part? in whole?) a function of the font itself?
I'm on a Mac at the moment, and with "regular" Textadept 9.4, I get three
different results with that "Cyrillic" browser test block:

http://www.fileformat.info/info/unicode/block/cyrillic/utf8test.htm

From worst to best = Monaco:


Fira Mono:


and Consolas:


The only thing that changed in those three screenshots is the font setting
in "init.lua".

FWIW!

David

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
ta-utf8-monaco.png ta-utf8-consolas.png ta-utf8-fira_mono.png
Received on Sat 13 May 2017 - 04:16:16 EDT

This archive was generated by hypermail 2.2.0 : Sat 13 May 2017 - 06:41:57 EDT