Re: [code][textadept] Textadept 10.0 alpha 2 (WIN32)

From: Danny MacMillan <foicica.att.nekulturny.org>
Date: Fri, 16 Mar 2018 17:25:30 -0600

... and I copied that useless init.lua onto my Linux machine and I
experience the problem there as well, so it seems it can't have anything
to do with WSL.

On 2018-03-16 17:23, Danny MacMillan wrote:
> I did a little more testing on this.
>
> I was using textadept_NIGHTLY_2018-03-15.x86_64 in WSL (Windows
> Subsystem for Linux) when I experienced this issue. The issue was
> repeatable. I tried opening textadept many times and each time, I was
> faced with a blank screen, until I pressed a key.
>
> Interestingly, if I pressed a down-arrow while the screen was blank,
> it inserted the literal characters "[B]" (no quotes) into the buffer.
> The up-arrow inserted "[A]". The home key inserted "[H]" etc. It's as
> if it thought an escape character was sent and it was waiting for the
> rest of the terminal sequence ... or something.
>
> I then downloaded the same build on a Linux Mint 18.3 box and ran it
> with no issues.
>
> I compared the init.lua on the two systems and they were considerably
> different. On the box that did NOT work this was the entire init.lua:
>
> ---
> keys.cc = function() {
> ui.dialogs.msgbox({text = "I typed ctrl-c"})
> }
>
> keys.cv = function() {
> buffer.add_text("I typed ctrl-v")
> }
> ---
>
> I had been using this normally useless init.lua to test some issues
> with WSL so that I could report them to Microsoft.
>
> So I copied the init.lua from the working Linux box to my WSL box and
> started textadept - it ran with no issues.
>
> I put back the useless init.lua from above and started textadept - I
> am back to having a black screen when I start. Using the --nosession
> command line argument doesn't impact this behaviour.
>
> On 2018-03-16 16:56, Danny MacMillan wrote:
>> I'm also experiencing this issue, but my Locale is defined correctly
>> as far as I can tell.
>>
>> $ locale
>> LANG=en_US.UTF-8
>> LANGUAGE=
>> LC_CTYPE="en_US.UTF-8"
>> LC_NUMERIC="en_US.UTF-8"
>> LC_TIME="en_US.UTF-8"
>> LC_COLLATE="en_US.UTF-8"
>> LC_MONETARY="en_US.UTF-8"
>> LC_MESSAGES="en_US.UTF-8"
>> LC_PAPER="en_US.UTF-8"
>> LC_NAME="en_US.UTF-8"
>> LC_ADDRESS="en_US.UTF-8"
>> LC_TELEPHONE="en_US.UTF-8"
>> LC_MEASUREMENT="en_US.UTF-8"
>> LC_IDENTIFICATION="en_US.UTF-8"
>> LC_ALL=
>>
>> On 2018-03-09 23:13, Pedro Andres Aranda Gutierrez wrote:
>>> For what it may help. I'm creating my own .deb packages from the
>>> source code and I also had the problem of a black textadept-curses
>>> until I fixed the locale on my system. It was anyhow annoying me a
>>> lot
>>> with other packages, but once I put a 'decent' locale (not C)
>>> everything went smooth with textadept-curses.
>>>
>>> My .0002 cents,
>>> /PA
>>>
>>> On 9 March 2018 at 14:41, Mitchell <m.att.foicica.com> wrote:
>>>
>>>> Hi Peter,
>>>>
>>>> On Fri, 9 Mar 2018, Peter Rolf wrote:
>>>>
>>>>> Hi Mitchell,
>>>>>
>>>>> just copied the nightly build (2018-03-08/ Win32) and tested all
>>>>> binaries.
>>>>>
>>>>> The curses version starts with a pure black window, no interface
>>>>> is
>>>>> shown. I have to type something into the window to 'bring it to
>>>>> life'.
>>>>>
>>>>> Both jit versions doesn't start (0xc000007b). Looks like a lib
>>>>> (libgcc_s_sjlj-1.dll) is missing here.
>>>>>
>>>>> No problems with the 'normal' version (the only one I use).
>>>>
>>>> Thanks very much for the reports. I will look into this. I recently
>>>> switched compilers, so that's probably the culprit.
>>>>
>>>> Cheers,
>>>> Mitchell
>>>>
>>>> --
>>>> You are subscribed to code.att.foicica.com.
>>>> To change subscription settings, send an e-mail to
>>>> code+help.att.foicica.com.
>>>> To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
>>>
>>> --
>>>
>>> Fragen sind nicht da um beantwortet zu werden,
>>> Fragen sind da um gestellet zu werden
>>> Georg Kreisler

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Fri 16 Mar 2018 - 19:25:30 EDT

This archive was generated by hypermail 2.2.0 : Sat 17 Mar 2018 - 06:25:57 EDT