Re: [code] [textadept] Request for a Mac Tester

From: Pedro Andres Aranda Gutierrez <paaguti.att.gmail.com>
Date: Sat, 21 Apr 2018 06:49:59 +0200

Hi Mitchell,

happy to help. Output of my tests:

paag.att.paag:~/.../Contents/MacOS$ ./textadept_osx
dyld: Library not loaded: /usr/local/opt/glib/lib/libglib-2.0.0.dylib
  Referenced from: /usr/local/lib/libharfbuzz.0.dylib
  Reason: Incompatible library version: libharfbuzz.0.dylib requires
version 5601.0.0 or later, but libglib-2.0.0.dylib provides version 4003.0.0
Abort trap: 6

I also tried

export DYLD_LIBRARY_PATH="$DYLD_LIBRARY_PATH:$bundle_res/lib"

With your suggestion, I have printed the values of DYLD_LIBRARY_PATH before
and after changing its value:

paag.att.paag:~/.../Contents/MacOS$ ./textadept_osx
DYLD_LIBRARY_PATH =
DYLD_LIBRARY_PATH =
/Users/paag/Downloads/textadept_NIGHTLY_2018-04-20.osx/Textadept.app/Contents/Resources/lib
dyld: Library not loaded: /usr/local/opt/glib/lib/libglib-2.0.0.dylib
  Referenced from: /usr/local/lib/libharfbuzz.0.dylib
  Reason: Incompatible library version: libharfbuzz.0.dylib requires
version 5601.0.0 or later, but libglib-2.0.0.dylib provides version 4003.0.0
Abort trap: 6

Just in case this can somehow help: I have home-brew installed on my
Macbook Pro where I'm running macOS Sierra. The behaviour on my Macbook Air
running High Sierra is different, because I'm not using Homebrew there. I
continue the thread from there

/PA

On 21 April 2018 at 00:39, Mitchell <m.att.foicica.com> wrote:

> Hi Pedro,
>
> On Fri, 20 Apr 2018, Pedro Andres Aranda Gutierrez wrote:
>
> Hi Mitchell
>>
>> the nightly doesn't work. And here's the transcript
>>
>> paag.att.paag:~/..._2018-04-20.osx$ cd Textadept.app/Contents/MacOS/
>> paag.att.paag:~/.../Contents/MacOS$ ls
>> textadept textadept_osx textadeptjit-curses
>> textadept-curses textadeptjit
>> paag.att.paag:~/.../Contents/MacOS$ ./textadept_osx
>> dyld: Library not loaded: /usr/local/opt/glib/lib/libglib-2.0.0.dylib
>> Referenced from: /usr/local/lib/libharfbuzz.0.dylib
>> Reason: Incompatible library version: libharfbuzz.0.dylib requires
>> version 5601.0.0 or later, but libglib-2.0.0.dylib provides version
>> 4003.0.0
>> Abort trap: 6
>>
>> I used textadept_osx, because textadept (plain) has problems referencing
>> the libraries:
>>
>
> Thank you for testing. You were correct to run `./textadept_osx`, not
> `./textadept`. Sorry for overlooking that.
>
> Please try something for me. Open *Contents/MacOS/textadept_osx* for
> editing and on line 7 you'll see an export for `DYLD_LIBRARY_PATH`. Please
> change that line to:
>
> export DYLD_LIBRARY_PATH="$bundle_res/lib"
>
> Then re-run `./textadept_osx` and report any error output.
>
> Thank you very much.
>
>
> Cheers,
> Mitchell
> --
> You are subscribed to code.att.foicica.com.
> To change subscription settings, send an e-mail to code+help.att.foicica.com.
> To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
>
>

-- 
Fragen sind nicht da um beantwortet zu werden,
Fragen sind da um gestellet zu werden
Georg Kreisler
-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Sat 21 Apr 2018 - 00:49:59 EDT

This archive was generated by hypermail 2.2.0 : Sat 21 Apr 2018 - 06:42:22 EDT