[code] [textadept] Poll: LuaJIT Version Users

From: Mitchell <m.att.foicica.com>
Date: Mon, 23 Apr 2018 17:30:12 -0400 (EDT)

Hi,

Back in 2014 (wow, it's been longer than I thought) I polled[1] this list for users of Textadept's LuaJIT version. Recent experiments with 64-bit Mac builds have yielded some LuaJIT pain, so Robert suggested another poll in order to potentially save me some trouble :)

Poll: is there anyone still using the LuaJIT version of Textadept? (textadeptjit.exe on Windows, Textadept.app with TEXTADEPTJIT=1 env variable on Mac, textadeptjit on Linux/BSD) If so, what OS are you running on?

As a refresher, from the FAQ[2]: "Other than access to the FFI Library, textadeptjit does not provide any noteworthy benefits. It used to be the case that textadeptjit was slightly faster when loading large files, but Textadept 6.1 was the last version that had a noticible difference between the two." Note that 6.1 was released at the end of 2012 (more than 5 years ago).

This is not a "majority rules" poll. If the JIT version is critical to your line of work, then I'll keep working on it. As I recall, we had one such responder to 2014's poll despite all other responses being in favor of dropping LuaJIT support.

Cheers,
Mitchell

[1]: https://foicica.com/lists/code/201412/2186.html
[2]: https://foicica.com/textadept/FAQ.html

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Mon 23 Apr 2018 - 17:30:12 EDT

This archive was generated by hypermail 2.2.0 : Tue 24 Apr 2018 - 06:47:15 EDT