Re: [code] [textadept] Possible bug?

From: Mitchell <m.att.foicica.com>
Date: Thu, 10 May 2018 09:53:23 -0400 (EDT)

Hi James,

On Wed, 9 May 2018, triplejam wrote:

> I've tried my best to figure it out. Although compiling Hunspell gives more debugging info, the place where it segfaults still says ??. It's hard to trigger debugging too because it only seems to crash like a third or fourth of the times after I do reset(). The most helpful info I got sometimes is a warning message from gdb in after the reset() which says:
>
> Continuing.
> warning: Temporarily disabling breakpoints for unloade
> d shared library "/home/james/.textadept/modules/spell
> check/spell64.so"
>
> Then as soon as I save:
>
> Thread 1 "textadept" received signal SIGSEGV, Segmenta
> tion fault.
> 0x00007f649a004e66 in ?? ()
>
> And when it does work right those other times I can step through the lspell.cxx file and hunspell.

Thanks for all of your time and patience looking into this.

I have no idea why the backtrace is not identifying the spellcheck module or hunspell as the source of the crash. I'm beginning to question that it is. However, you said earlier you narrowed it down to a line of code in the spellcheck module.

I'm afraid I do not know how to proceed :(

Cheers,
Mitchell

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Thu 10 May 2018 - 09:53:23 EDT

This archive was generated by hypermail 2.2.0 : Fri 11 May 2018 - 06:25:33 EDT