Re: [code] Textadept copying bytes causes crash

From: Colin <colin.holzman.att.protonmail.com>
Date: Thu, 06 Sep 2018 11:21:58 +0000

It looks like buffer.code_page is 0. I don't see an encoding in the lower right. I set buffer.code_page = 0 in my events.FILE_OPENED handler, but I the issue is still present.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On 5 September 2018 9:01 PM, Mitchell <m.att.foicica.com> wrote:

> Hi Colin,
>
> On Wed, 5 Sep 2018, Colin wrote:
>
> > I am using Windows. I am able to copy arbitrary bytes from my test file opened in SciTE and paste them into Textadept, but coping the same bytes from Textadept causes a crash.
>
> For some reason, it seems like`buffer.code_page` is not equal to 0 when it should be. Does Textadept show an encoding at the bottom right of your status bar? Or does it just show your indentation settings?
>
> Try setting `buffer.code_page = 0` in your `events.FILE_OPENED` handler or wherever you are setting your buffer character representations.
>
> Cheers,
> Mitchell
>
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> You are subscribed to code.att.foicica.com.
> To change subscription settings, send an e-mail to code+help.att.foicica.com.
> To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Thu 06 Sep 2018 - 07:21:58 EDT

This archive was generated by hypermail 2.2.0 : Fri 07 Sep 2018 - 06:53:18 EDT