Re: [code] [textadept] Seg fault on NixOS

From: Jonathan Levi <catanscout.att.gmail.com>
Date: Fri, 26 Apr 2019 18:24:21 -0500

Thanks for helping Julien,

When I run ldd on textadept it shows that it finds everything.

On Mon, Apr 22, 2019 at 12:03 PM Julien L. <julienl81.att.hotmail.com> wrote:

> Hello Jonathan,
>
> I am running Textadept on GNU Guix, which is a similar distribution to
> NixOS. I may help you.
>
> > bash: ./textadept: No such file or directory
> I think that the problem is that the binary statically makes reference
> to /lib/ld-linux-x86-64.so.2 or something similar. This is the dynamic
> loader which takes care of loading the binary. You should be able to
> verify this assumption by running:
> $ ldd textadept
>
> If this is the problem, then it means that you have to execute Textadept
> by running:
> $ <path to glibc>/lib/ld-linux-x86-64.so.2 textadept
>
> I had tried it on GNU Guix. Unfortunately it failed finding Lua files to
> initialize itself, and there is no (documented) way to specify Textadept
> where to find these Lua files.
>
> If you have an issue with Textadept using the official package from Nix,
> then I tend to think that you should contact the maintainer of the package.
>
> Best regards,
>
> --
> Julien L.
> Diaspora*: julien1001.att.diasp.eu
>
> Le 20/04/19 à 04:28, Jonathan Levi a écrit :
> > Okay, I fixed the download problem, just after sending that I realized
> > chrome had partially downloaded files, and they appeared to be the
> problem.
> >
> > On Fri, Apr 19, 2019 at 9:24 PM Jonathan Levi <catanscout.att.gmail.com
> > <mailto:catanscout.att.gmail.com>> wrote:
> >
> > When I try to download the nightly my browser crashes. I downloaded
> > it with wget and it seems to work correctly until I try running it
> > when I get "bash: ./textadept: No such file or directory".
> >
> > Do you have any idea what that is?
> > Jonathan
> >
> > On Tue, Apr 16, 2019 at 12:07 PM Mitchell <m.att.foicica.com
> > <mailto:m.att.foicica.com>> wrote:
> >
> > Hi Jonathan,
> >
> > On Tue, 16 Apr 2019, Jonathan Levi wrote:
> >
> > > I installed Textadept on my new NixOS rig. When I try
> > running texted adept
> > > though it merely logs "Segmentation Fault". I also tried
> > running the
> > > latest (v10.3) binary for Linux x86_64 off you wesbsite and
> > the same
> > > happens.
> > >
> > > Any idea how to fix? Or is there a way I can get you a
> > better crash report?
> >
> > You can do one of two things:
> >
> > 1. Download a nightly build, which has debug symbols enabled,
> > and run it via gdb to get a nicer backtrace.
> > 2. Build from the source (see the manual for more info, but
> > basically: `make deps && make`) and see if it's a library issue
> > related to your machine/os/etc.
> >
> > Cheers,
> > Mitchell
> > --
> > You are subscribed to code.att.foicica.com <mailto:code.att.foicica.com
> >.
> > To change subscription settings, send an e-mail to
> > code+help.att.foicica.com <mailto:code%2Bhelp.att.foicica.com>.
> > To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com
> > <mailto:code%2Bunsubscribe.att.foicica.com>.
> >
>

-- 
You are subscribed to code.att.foicica.com.
To change subscription settings, send an e-mail to code+help.att.foicica.com.
To unsubscribe, send an e-mail to code+unsubscribe.att.foicica.com.
Received on Fri 26 Apr 2019 - 19:24:21 EDT

This archive was generated by hypermail 2.2.0 : Sat 27 Apr 2019 - 06:30:00 EDT