Re: Lua Error: error loading module 'bit' when running textadept

From: mitchell <mforal.n....at.gmail.com>
Date: Wed, 12 Nov 2008 06:22:05 -0800 (PST)

Hi,

> Do I need lua-dev? It seems like this is a path issue, with the
> duplicated slashes meaning the the file (bit.so - which exists in the /
> usr/share/textadept/lexers/ folder) can't be found by textadept?

According to your error:
Lua Error: error loading module 'bit' from file '/usr/share/
textadept//
lexers//bit.so':
       liblua.so: cannot open shared object file: No such file or
directory.

bit was found and attempted to load, but because liblua.so was not
found, it failed. You need liblua.so to be on your system. Maybe
ubuntu calls it liblua5.1.so or something of the sort. If so, make a
symlink.
Received on Wed 12 Nov 2008 - 09:22:05 EST

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 11:37:05 EST