Re: Lua Error: error loading module 'bit' when running textadept

From: dflock <duncan.l....at.gmail.com>
Date: Wed, 12 Nov 2008 06:48:10 -0800 (PST)

Great! Thanks for the explanation - much clearer now. I've now fixed
this issue and textadept appears to work much better - I get syntax
highlighting now, for a start.

Apparently installing the 'lua5.1' package on my system installed the
actual liblua library as /usr/lib/liblua5.1.so.0.0.0, and a handy
symlink pointing to it called 'liblua5.1.so.0'.

I'm not sure what all the zero's are for - maybe so you can have
multiple versions installed at once? Or maybe I installed the wrong
package?

Anyway, I created a symlink in /usr/lib called 'liblua.so' which
points to 'liblua5.1.so.0.0.0' and that got things working. Here are
the shell commands in case anyone else wants them:

cd /usr/lib/
sudo ln liblua5.1.so.0.0.0 liblua.so

Thanks for your help!
Dunc

On Nov 12, 2:23 pm, mitchell <mforal.n....at.gmail.com> wrote:
> > I can't find the lua-dev package to install. It isn't in the Ubuntu
> > repo's anywhere and neither google or getdeb were any help.
>
> liblua5.1-dev I think is the package name.
>
Received on Wed 12 Nov 2008 - 09:48:10 EST

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 11:37:05 EST