Re: ctags under windows

From: dmsacks <dennis.sa....at.gmail.com>
Date: Mon, 9 Nov 2009 15:12:53 -0800 (PST)

Hi, so I think popen could work for this. I get an error if I try to
use os.popen - is it not compiled into the lua used by textadept?

Dennis

On Oct 1, 8:39 am, mitchell <mforal.n....at.gmail.com> wrote:
> Hi,
>
> > It looks like you can't avoid the clunky dos box popping up unless you
> > add custom code to your lua code:
>
> > see the thread starting here:http://lua-users.org/lists/lua-l/2008-09/threads.html#00137
>
> > and one of the solutions suggested in the thread:
>
> >http://lua-users.org/lists/lua-l/2008-09/msg00145.html
>
> I wonder if io.popen could be used in some way? That might be cleaner.
>
> -Mitchell;
>
>
>
>
>
> > On Sep 29, 2:41 pm, dsacks <dennis.sa....at.gmail.com> wrote:
>
> > > Okay, I got this working under Win xp. I had to do two things:
>
> > > 1. Edited init.lua to comment out "if not WIN32 then" and "end":
>
> > > line 29 - 31:
> > > --if not WIN32 then
> > >   require 'ext/pm.ctags_browser' -- ctags browser
> > > --end
>
> > > 2. edit ctags_browser.lua to add the path to my ctags.exe to the
> > > os.execute() statement:
>
> > >     os.execute('\bin\bin\ctags.exe -f "'..FILE_OUT..'" '..
> > > (buffer.filename or ''))
>
> > > And this works, though a dos box flashes on the screen every time
> > > os.execute is called, which is clunky. Seeing if I can keep that from
> > > happening...
>
> > > On Sep 29, 1:48 pm, dmsacks <dennis.sa....at.gmail.com> wrote:
>
> > > > Can the ctags browser work under windows? I don't see it in the drop
Received on Mon 09 Nov 2009 - 18:12:53 EST

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 11:38:40 EST