Re: Build process

From: mitchell <mforal.n....at.gmail.com>
Date: Wed, 16 Jun 2010 08:28:16 -0700 (PDT)

Robert,

On Jun 16, 11:23 am, Robert <ro....at.web.de> wrote:
> On Wed, Jun 16, 2010 at 4:09 PM, mitchell <mforal.n....at.gmail.com> wrote:
> > Ignore pthread; it's just a warning. Instead focus on the fact glib.h
> > and gmodule.h are not found.
>
> > Mitchell
>
> Thanks a lot for your help, I got a bit further and now I'm getting:
>
> i586-mingw32msvc-g++ -mms-bitfields -mwindows -rdynamic
> -Wl,--retain-symbols-file -Wl,lua.sym -o textadept.exe AutoComplete.o
> CallTip.o CellBuffer.o CharClassify.o ContractionState.o Decoration.o
> Document.o DocumentAccessor.o Editor.o ExternalLexer.o Indicator.o
> KeyMap.o KeyWords.o LexLPeg.o LineMarker.o PerLine.o PositionCache.o
> PropSet.o RESearch.o RunStyles.o ScintillaBase.o Selection.o Style.o
> StyleContext.o UniConversion.o ViewStyle.o WindowAccessor.o XPM.o
> PlatGTK.o ScintillaGTK.o scintilla-marshal.o textadept.o
> lua_interface.o lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o
> llex.o lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o
> ltable.o ltm.o lundump.o lvm.o lzio.o lauxlib.o lbaselib.o ldblib.o
> liolib.o lmathlib.o ltablib.o lstrlib.o loadlib.o loslib.o linit.o
> lpeg.o lfs.o gcocoadialog.o textadept_rc.o -Lwin32gtk/lib
> -lgtk-win32-2.0 -lgdk-win32-2.0 -latk-1.0 -lgio-2.0 -lgdk_pixbuf-2.0
> -lpangowin32-1.0 -lgdi32 -lpangocairo-1.0 -lpango-1.0 -lcairo
> -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lintl
> i586-mingw32msvc-g++: unrecognized option '-rdynamic'
> PlatGTK.o:PlatGTK.cxx:(.text$_ZN18DynamicLibraryImplC1EPKc[DynamicLibraryImpl::DynamicLibraryImpl(char
> const*)]+0x4b): undefined reference to `_g_module_open'
> textadept.o:textadept.c:(.text+0x13ef): undefined reference to
> `_gdk_pixbuf_new_from_file'
> collect2: ld returned 1 exit status
> make: *** [textadept.exe] Error 1

It appears the appropriate .a files (formerly .dll.a as mentioned in
the Compiling manual page) are not in your library path.

The windows build process is a pain. I hope it's not too frustrating
for you. At the end of the day I can post my directory listing for
reference if it's still not working.

Mitchell

>
> Any pointers much appreciated :-)
Received on Wed 16 Jun 2010 - 11:28:16 EDT

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 11:47:21 EST