Re: Obscure bug of the week

From: Brian Schott <briancsch....at.gmail.com>
Date: Mon, 21 Jun 2010 16:52:10 -0700

I'll try to reproduce it later tonight with a clean install of the TA3 beta.

On Mon, Jun 21, 2010 at 4:17 PM, mitchell <mforal.n....at.gmail.com> wrote:
> Robert,
>
>>
>> This is probably unrelated but it reminded me of a bug I now tracked down.
>> When using "save_as" in file_io.lua a check should be added to make
>> sure that no buffer with the same path and name is already open,
>> otherwise you get two buffers with the same filename and the reloading
>> problem as you switch buffers.
>
> I just tried this and while I am prompted with the reload dialog, I do
> not get any ill behavior afterword, at least nothing of the likes
> Brian mentioned. I guess I just do not understand what the bug is
> here.
>
> Mitchell
>
>> So after the dialog, line 276 in file_io.lua
>> for i=1, #_BUFFERS do
>>   if _BUFFERS[i].filename == utf8_filename then
>>     -- some error message to give the user the possibility
>>     --  to close the other buffer or try saving as again with another name
>>     return
>>   end
>> end
>>
>> Robert
>
> --
> You received this message because you are subscribed to the Google Groups "textadept" group.
> To post to this group, send email to textadept.at.googlegroups.com.
> To unsubscribe from this group, send email to textadept+unsubscribe.at.googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/textadept?hl=en.
>
>
Received on Mon 21 Jun 2010 - 19:52:10 EDT

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 11:48:31 EST