Re: [textadept] Changing folding symbol to MARK_BOX* tree doesn't work

From: Robert <ro....at.web.de>
Date: Sat, 14 May 2011 10:17:36 +0200

Hi Victor,

have you seen the Alaran-Dark theme on the wiki?
http://caladbolg.net/textadeptwiki/index.php?n=Main.Alarandark3
I don't know how this works (with Scintilla's theming) but this might
be an easier starting point than the Scite theme.

Robert

On Sat, May 14, 2011 at 3:17 AM, Victor T. <google.greatw....at.mamber.net> wrote:
> Hi,
>
> I'm trying textadept out since I wanted a clean extensible code editor
> that uses lua scripting. I downloaded it and played around a bit.
> However I am running into a bit of problem trying to change the
> folding symbols into a boxtree.
>
> Here's what I did:
>
>  - Copied scite theme and renamed it to scitemod as a starting base
>  - In my user doc folder I added a theme file containing scitemod as
> the first line per instructions
>  - I modified view.lua in /scitemod folder as follows:
>
> -- Fold Margin Markers.
> buffer:marker_define(c.SC_MARKNUM_FOLDEROPEN, c.SC_MARK_BOXMINUS)
> buffer:marker_set_fore(c.SC_MARKNUM_FOLDEROPEN, 0xFFFFFF)
> buffer:marker_set_back(c.SC_MARKNUM_FOLDEROPEN, 0x8F8F8F)
>
> buffer:marker_define(c.SC_MARKNUM_FOLDER, c.SC_MARK_BOXPLUS)
> buffer:marker_set_fore(c.SC_MARKNUM_FOLDER, 0xFFFFFF)
> buffer:marker_set_back(c.SC_MARKNUM_FOLDER, 0x8F8F8F)
>
> buffer:marker_define(c.SC_MARKNUM_FOLDERSUB, c.SC_MARK_VLINE)
> buffer:marker_set_fore(c.SC_MARKNUM_FOLDERSUB, 0xFFFFFF)
> buffer:marker_set_back(c.SC_MARKNUM_FOLDERSUB, 0x8F8F8F)
>
> buffer:marker_define(c.SC_MARKNUM_FOLDERTAIL, c.SC_MARK_LCORNER)
> buffer:marker_define(c.SC_MARKNUM_FOLDEREND,
> c.SC_MARK_BOXPLUSCONNECTED)
> buffer:marker_define(c.SC_MARKNUM_FOLDEROPENMID,
> c.SC_MARK_BOXMINUSCONNECTED)
> buffer:marker_define(c.SC_MARKNUM_FOLDERMIDTAIL, c.SC_MARK_TCORNER)
>
> Basically I followed the setting in the scite doc here:
> http://www.scintilla.org/ScintillaDoc.html#Markers. However the
> symbols don't appear properly. The +, - boxes show up in black instead
> of grey color and the vertical lines, closing L lines, and T lines are
> missing altogether. Any idea what the problem is?
>
> Thanks
>
> --
> You received this message because you are subscribed to the Google Groups "textadept" group.
> To post to this group, send email to textadept.at.googlegroups.com.
> To unsubscribe from this group, send email to textadept+unsubscribe.at.googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/textadept?hl=en.
>
>
Received on Sat 14 May 2011 - 04:17:36 EDT

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 12:06:43 EST