Re: [textadept] Mime-type.lua errors in version 4.1

From: mitchell <c....at.caladbolg.net>
Date: Thu, 6 Oct 2011 12:41:01 -0400 (Eastern Daylight Time)

Hi Ryan,

On Thu, 6 Oct 2011, Ryan Pusztai wrote:

> Hi,
> I recently updated to TA v4.1 and now I get an error when opening files with the .md file extension.
> Not sure what the issue is and
> I hope it is not from my .textadept/ changes. I have not touched anything related to the mime-types,
> except added a '' file to help load
> the correct lexer for some custom file types.
>
> I am running Ubuntu 11.04 x64
>
> Here is the error:
> � ��...extadept_4.1.x86_64/modules/textadept/mime_types.lua:135: attempt to index field '?' (a nil
> value)

Your markdown module does not have a set_buffer_properties() function. All
language-specific modules should have this function. This may not have
been the case in the past, but at some point it became required.

mitchell

> When I press <Tab> it also throws this error:
> � ��.../textadept_4.1.x86_64/modules/textadept/snippets.lua:188: attempt to index local 'snip' (a
> function value)
>
> Here is my mime_types.conf contents:
> � ��% Lua
> � � wlua lua
> � � lexe lua
> � � job lua
> --Regards,
> Ryan
>
> --
> You received this message because you are subscribed to the Google Groups "textadept" group.
> To post to this group, send email to textadept.at.googlegroups.com.
> To unsubscribe from this group, send email to textadept+unsubscribe.at.googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/textadept?hl=en.
>
>

mitchell
Received on Thu 06 Oct 2011 - 12:41:01 EDT

This archive was generated by hypermail 2.2.0 : Thu 08 Mar 2012 - 12:23:37 EST